Raketenmodellbau.org Portal > Forum > Rund um den Raketenmodellbau > Probleme & FAQ > OPen Rocket lädt keine eigenen Motoren ein.
Du kannst keine neue Antwort schreiben
Seiten (2): [1] 2 »

Autor Thema 
Neil

99.9% harmless nerd


Administrator

Neil

Registriert seit: Aug 2000

Wohnort: Delft

Verein: SOLARIS

Beiträge: 7776

Status: Offline

Beitrag 7585901 , OPen Rocket lädt keine eigenen Motoren ein. [Alter Beitrag01. Juli 2011 um 11:14]

[Melden] Profil von Neil anzeigen    Neil eine private Nachricht schicken   Neil besitzt keine Homepage    Mehr Beiträge von Neil finden

Hallo,

ich wollte in Open Rocket ein eigenen Motor laden. Die Stelle wo man das macht habe ich auch relativ schnell gefunden. Jetzt ist es aber so, das trotz der Anleitung in dem Fenster, kein eigener Motor zur Auswahl steht. Ich habe sogar den Pfad zu den standard Motoren gelöscht so das eigentlich kein Motor mehr in der Liste stehen sollte. Aber die stehen da immer noch. Für mich sieht es so aus, als ob Open Rocket da einfach nichts übernimmt. Nach einem Neustart des Programms sollte das ja übernommen worden sein. Laut dem Fenster wurde auch der Pfad gemerkt. Aber wie gesagt nichts eigenes.
Weiß jemand die Lösung?

Gruß

Neil

Die Erde ist eine Scheibe. Egal in welche Richtung sich die Menschheit bewegt, sie geht immer auf einen Abgrund zu.


schmidi093

Epoxy-Meister

schmidi093

Registriert seit: Apr 2009

Wohnort:

Verein: Solaris RMB, AGM

Beiträge: 431

Status: Offline

Beitrag 7587951 [Alter Beitrag01. Juli 2011 um 14:32]

[Melden] Profil von schmidi093 anzeigen    schmidi093 eine private Nachricht schicken   schmidi093 besitzt keine Homepage    Mehr Beiträge von schmidi093 finden

Hi Neil,

könnte das sein das dein Motorfile einfach zu viele Datenpunkte aufweist? Bei Rocksim ist es meines Wissens nach so das nur Motorfiles mit beschränkter Anzahl an Datenpunkten verarbeitet werden können. Die meisten Motoren in Openrocket haben ca. 20-30 Datenpunkte. Das maximale ist glaub 70.
Vielleicht haben deine Daten aber auch das falsche Format.

Mal ein Beispiel: Das Datenfile der BC Motoren funktioniert bei mir einwandfrei
Anhang: bc.txt

Alternativ zum auswählen des Motorfiles im Programm kannst du deine Daten unter Windows auch einfach nach Benutzer/Benutzername(Neil)/AppData/Roaming/OpenRocket/ThrustCurves
kopieren. So sollten die Daten im Motorauswahlmenü auftauchen.


Viele Grüße
Thomas
Neil

99.9% harmless nerd


Administrator

Neil

Registriert seit: Aug 2000

Wohnort: Delft

Verein: SOLARIS

Beiträge: 7776

Status: Offline

Beitrag 7587952 [Alter Beitrag01. Juli 2011 um 14:45]

[Melden] Profil von Neil anzeigen    Neil eine private Nachricht schicken   Neil besitzt keine Homepage    Mehr Beiträge von Neil finden

Hi,

danke erstmal für die Hilfe.
An der Anzahl von Punkten hat es nicht gelegen.
Meine Open Rocket Version ist eine ausführbare *.JAR Datei. Das ist ein gepackter Ordner. Ich habe da mal rein geschaut und dann den Ordner mit den Motor Dateien gefunden. Dort die Datei hin kopiert und noch in der Index Datei ergänzt, und schon lief es.

Gruß

Neil

Die Erde ist eine Scheibe. Egal in welche Richtung sich die Menschheit bewegt, sie geht immer auf einen Abgrund zu.


Johannes (Axe) Haux

Poseidon

Johannes (Axe) Haux

Registriert seit: Okt 2000

Wohnort: D-73035 Göppingen-Jebenhausen

Verein: HGV, AGM, TRA #7891 L2 z.Zt. inaktiv

Beiträge: 1067

Status: Offline

Beitrag 7591900 [Alter Beitrag02. Juli 2011 um 19:55]

[Melden] Profil von Johannes (Axe) Haux anzeigen    Johannes (Axe) Haux eine private Nachricht schicken   Johannes (Axe) Haux besitzt keine Homepage    Mehr Beiträge von Johannes (Axe) Haux finden

Hi Neil,

auf Grund Deines Posts habe ich das jar auch ausgepackt.

.... Nun ist die Frage, wie starte ich OpenRocket?
Im Readme steht:
Zitat:
To start the software run the class

net.sf.openrocket.startup.Startup



und wie geht das? Das Executable bit hab ich schon gesetzt, das hilft aber nicht.

Mit OpenJDK passiert überhaupt nicht, mit Sun: "Anwendung konnte nicht gestartet werden".

Auf der Shell:
----------------------------------------Start------------------------
$ java Startup.class
Exception in thread "main" java.lang.NoClassDefFoundError: Startup/class
Caused by: java.lang.ClassNotFoundException: Startup.class
at java.net.URLClassLoader$1.run(URLClassLoader.java:217)
at java.security.AccessController.doPrivileged(Native Method)
at java.net.URLClassLoader.findClass(URLClassLoader.java:205)
at java.lang.ClassLoader.loadClass(ClassLoader.java:321)
at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:294)
at java.lang.ClassLoader.loadClass(ClassLoader.java:266)
Could not find the main class: Startup.class. Program will exit.
-----------------------------------------End-----------------------------

Leider hab ich mit Java absolut nichts am Hut.

Gruß Johannes

Die Zensur ist das lebendige Geständnis der Großen, daß sie nur verdummte Sklaven aber keine freien Völker regieren können. (Johann Nepomuk Nestroy)
Das Merkwürdige an der Zukunft ist wohl die Vorstellung, daß man unsere Zeit einmal die gute alte Zeit nennen wird. (Ernest Hemingway)
Es wird niemals so viel gelogen wie vor der Wahl, während des Krieges und nach der Jagd. (Otto Fürst von Bismarck)
schmidi093

Epoxy-Meister

schmidi093

Registriert seit: Apr 2009

Wohnort:

Verein: Solaris RMB, AGM

Beiträge: 431

Status: Offline

Beitrag 7591901 [Alter Beitrag02. Juli 2011 um 21:43]

[Melden] Profil von schmidi093 anzeigen    schmidi093 eine private Nachricht schicken   schmidi093 besitzt keine Homepage    Mehr Beiträge von schmidi093 finden

Falls du Ubuntu verwendest gehts hier mit im Terminal

sudo apt-get install openrocket

Gruß
Thomas


Geändert von schmidi093 am 02. Juli 2011 um 21:54

Johannes (Axe) Haux

Poseidon

Johannes (Axe) Haux

Registriert seit: Okt 2000

Wohnort: D-73035 Göppingen-Jebenhausen

Verein: HGV, AGM, TRA #7891 L2 z.Zt. inaktiv

Beiträge: 1067

Status: Offline

Beitrag 7595905 , Leider nicht [Alter Beitrag03. Juli 2011 um 18:54]

[Melden] Profil von Johannes (Axe) Haux anzeigen    Johannes (Axe) Haux eine private Nachricht schicken   Johannes (Axe) Haux besitzt keine Homepage    Mehr Beiträge von Johannes (Axe) Haux finden

Zitat:

~$ sudo apt-get install Openrocket
Paketlisten werden gelesen... Fertig
Abhängigkeitsbaum wird aufgebaut
Status-Informationen einlesen... Fertig
E: Paket Openrocket konnte nicht gefunden werden
~$ echo $?
100




Ubuntu 10.4 LTS 64Bit

Was mich irritiert: Woher kommt das "E:"? Das ist doch M$?

Gruß Johannes

Edit: Mit kleingeschriebenem "openrocket" geht es auch nicht - identische Fehlermeldung

Geändert von Johannes (Axe) Haux am 03. Juli 2011 um 18:55


Die Zensur ist das lebendige Geständnis der Großen, daß sie nur verdummte Sklaven aber keine freien Völker regieren können. (Johann Nepomuk Nestroy)
Das Merkwürdige an der Zukunft ist wohl die Vorstellung, daß man unsere Zeit einmal die gute alte Zeit nennen wird. (Ernest Hemingway)
Es wird niemals so viel gelogen wie vor der Wahl, während des Krieges und nach der Jagd. (Otto Fürst von Bismarck)
schmidi093

Epoxy-Meister

schmidi093

Registriert seit: Apr 2009

Wohnort:

Verein: Solaris RMB, AGM

Beiträge: 431

Status: Offline

Beitrag 7596901 [Alter Beitrag03. Juli 2011 um 20:18]

[Melden] Profil von schmidi093 anzeigen    schmidi093 eine private Nachricht schicken   schmidi093 besitzt keine Homepage    Mehr Beiträge von schmidi093 finden

Hi Johannes,

eventuel hast du die Paketquelle einfach nicht aktzeptiert.

Geh unter Ubuntu Classic einfach mal auf das Softwarecenter: Bearbeiten/ Software-Paketquellen
Dort stellst du erstmal auf den Hauptserver. Bei "Von der Ubuntu-Gemeinschaft betreute Open-Source Software (universe)" machst du einen Hacken (weiter Hacken bei main, der Rest ist hierfür irrelevant). Im Reiter "Andere Software setzt du bei den Canonical Partnern den Hacken. Nun probier einfach nochmal über das Terminal zu installieren.

Eigentlich solltest du OpenRocket auch im Software Center finden (zusammen schreiben). Einfach mal suchen. Bei mir gehts.

Viele Grüße
Thomas
Johannes (Axe) Haux

Poseidon

Johannes (Axe) Haux

Registriert seit: Okt 2000

Wohnort: D-73035 Göppingen-Jebenhausen

Verein: HGV, AGM, TRA #7891 L2 z.Zt. inaktiv

Beiträge: 1067

Status: Offline

Beitrag 7601001 [Alter Beitrag04. Juli 2011 um 17:07]

[Melden] Profil von Johannes (Axe) Haux anzeigen    Johannes (Axe) Haux eine private Nachricht schicken   Johannes (Axe) Haux besitzt keine Homepage    Mehr Beiträge von Johannes (Axe) Haux finden

Zitat:
Original geschrieben von schmidi093

Hi Johannes,

eventuel hast du die Paketquelle einfach nicht aktzeptiert.
Bei mir gehts.




Anscheinend ist das 10.4 LTS daran schuld. In der Firma mit 11.4 ist alles kein Problem (ausser daß man nicht die aktuelle Version bekommt).

Leider zieht er dort auch nur das .jar herunter und startet es über ein Wrapper-Script "openrocket" in /usr/bin mit java -jar.

Aber wenn ich das .jar auspacke bekomme ich es nicht mehr gestartet und wie Neil schrieb muss man die Motoren an die bestimmte Stelle kopieren und eine Datei ändernconfused.

Neil ????? - wie starte ich nach dem Auspacken? Oder muss ich wieder einpacken?

Gruß Johannes

Die Zensur ist das lebendige Geständnis der Großen, daß sie nur verdummte Sklaven aber keine freien Völker regieren können. (Johann Nepomuk Nestroy)
Das Merkwürdige an der Zukunft ist wohl die Vorstellung, daß man unsere Zeit einmal die gute alte Zeit nennen wird. (Ernest Hemingway)
Es wird niemals so viel gelogen wie vor der Wahl, während des Krieges und nach der Jagd. (Otto Fürst von Bismarck)
MarkusJ

Gardena Master of Rocketry


Moderator

Registriert seit: Apr 2005

Wohnort: Kandel

Verein:

Beiträge: 2148

Status: Offline

Beitrag 7602903 [Alter Beitrag04. Juli 2011 um 18:56]

[Melden] Profil von MarkusJ anzeigen    MarkusJ eine private Nachricht schicken   MarkusJ besitzt keine Homepage    Mehr Beiträge von MarkusJ finden

JAR-Files packt man nicht aus, sie sind in etwa das Java-Äquivalent zu einer .EXE.

mfG
Markus

WARNUNG: Dieser Beitrag kann Spuren von Ironie beinhalten
Ich bin weder eine Suchmaschine, noch ein Nachschlagewerk - PNs zu Themen die im Forum stehen oder dorthin gehören, werde ich nicht beantworten.
Bilder bitte NICHT über Imageshack oder andere Imagehoster einbinden!
Johannes (Axe) Haux

Poseidon

Johannes (Axe) Haux

Registriert seit: Okt 2000

Wohnort: D-73035 Göppingen-Jebenhausen

Verein: HGV, AGM, TRA #7891 L2 z.Zt. inaktiv

Beiträge: 1067

Status: Offline

Beitrag 7602906 [Alter Beitrag04. Juli 2011 um 19:55]

[Melden] Profil von Johannes (Axe) Haux anzeigen    Johannes (Axe) Haux eine private Nachricht schicken   Johannes (Axe) Haux besitzt keine Homepage    Mehr Beiträge von Johannes (Axe) Haux finden

Hi Markus,

wie gesagt, ich hab keine Ahnung von Java.

Wie bringe ich dann die neue Motoren in das Archiv?
Das ist ja dann so als ob ich ein EXE Patche?

Gruß Johannes

Die Zensur ist das lebendige Geständnis der Großen, daß sie nur verdummte Sklaven aber keine freien Völker regieren können. (Johann Nepomuk Nestroy)
Das Merkwürdige an der Zukunft ist wohl die Vorstellung, daß man unsere Zeit einmal die gute alte Zeit nennen wird. (Ernest Hemingway)
Es wird niemals so viel gelogen wie vor der Wahl, während des Krieges und nach der Jagd. (Otto Fürst von Bismarck)
Seiten (2): [1] 2 »
[Zurück zum Anfang]
Du kannst keine neue Antwort schreiben